
Day 02 - ICfL Make It at the Library
Basic electronics and Arduino

Nick Raymond
nraymond@makermedia.com



Overview

• Day 1
 Electronics and Breadboarding
 Lunch
 Arduino Basic Projects

• Day 2
 Arduino intermediate Projects
 Lunch
 Wearable’s and E-textiles



Workshop Files

• Please copy files form one of the flash drives, 
they will have Fritizing files and Arduino
sketches.

• Also, additional software and libraries to 
install for Day 03



Workshop Format

• Workshop presenters
– Nick Raymond
– Adam Day

• Hands on workshop
– Build the circuits
– There will be problems
– Ask us for help, thanks why we are here!



About myself…
• Nick Raymond – Maker Media – ndraymond@makermedia.com

• BS Mechanical Engineering (UD Davis)
• MS Student – emphasis in manufacturing and 

mechatronics
• Hobbies

– Beer brewing
– Surfing
– 3D Printing
– CNC machines
– Wood working
– Electronics/Arduino



About myself…

• Ocean powered wave energy 
converter – 2012/2013

• Open source Ocean Wave Buoy 
Project - ongoing

https://oceanpowerproject.wordpress.com/wave-energy/
https://opensourceoceanweatherbuoy.wordpress.com/


Electrical Component Symbols
• Resistors 

• Capacitors

• Inductors

• Diodes

• Transistor

• Voltage source

Transistor



Electrical components

• Potentiometers

• Light Emitting Diode (LED)

• Motor

• Battery

• Speaker

M



Voltage – Current - Resistance

Image: Sparkfun.com



Current vs. Voltage

Source: http://www.diffen.com/difference/Current_vs_Voltage



Ohm’s Law

Source: http://www.electronics-tutorials.ws/dccircuits/dcp_2.html



Breadboard LayoutPower Rails

Terminal 
Rails

DIP Channel



Breadboard “Insides”

Images – sparkfun.com



Breadboards



Basic LED + Switch circuit



Build the Circuit



Step 1



Step 2



Step 3



Step 4

Cathode
short leg (-)

Place the long leg of the LED in the +V rail near row 17, place the 
short leg in F17.

Anode
long leg (+)

column F



Step 5

Place the one leg of 330 ohm resistor into H17
(orange, orange, brown, gold) 



Step 6

Turn on the switch!



Remove the resistor…

Creates a break in the circuit, electrons cannot flow and 
LED turns off.



555 Timer IC

Indicator mark

“Integrated Circuit” = IC    and    “Dual Inline Package” = DIP



555 Timer IC
Astable – no stable state
- Switches between high and low, operates as 
an oscillator
- Used for motor control, flashing lamps and 
LED, or as a clock 

Monostable – one stable state
- One shot pulse of fixed length in response to 
input signal
-Ideal for “push to start” projects that will move 
then turn off after certain time.

Bistable – two stable states, high and low
-taking trigger input high makes output low,
- taking trigger input low makes output high
switches between two stable states based on 
the state of the inputs, great for ON/OFF switch

Source: http://www.555-timer-circuits.com/operating-modes.html



Project 2 - Materials
22 AWG wire

9V Battery

Breadboard

Alligator clips (x4)

0.01 uF Cap.

330 Ω resistor
555 IC

4.7MΩ resistor (x2)

LED



Project 02 - Schematic

“Bistable” Mode
4.7M ohm

4.7M ohm

0.01 uF
(103)

Source: www.bareconductive.com

Presenter
Presentation Notes
330 ohm ----- orange orange brown

4.7M ohm ---- yellow – purple - green



Paint the touch sensors

www.bareconductive.com



Paint the touch sensors

Conductive Ink Pen Conductive Ink Pots + Brush



Step 1

Insert the positive and negative battery wires into the power rails.
Use two more wires to jump power to the opposite side of the board. 



Step 2

Dimple

Place the 555 timer in the middle of the breadboard. 



Step 3

Connect Leg#1 to GND, connect Leg#4 to +V, connect Leg#8 to +V.
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4



Step 4

Jump a 330 ohm resistor from Leg#3  to the long leg of the LED. 
Then connect the short leg of LED to GND
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Step 5

5

` ` ` ` ` ` ` ` ` ```````````````

Jump 0.01 uf capacitor (103) from Leg#5 to GND.



Step 6

` ` ` ` ` ` ` ` ` `````````````

` ` ` ` ` ` ` ` ````````````` ` ``

`
`
`
`

`̀
`
`
`
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Jump 4.7M ohm resistor from Leg#2 to +V,
Jump 4.7M ohm resistor from Leg#6 to GND

4.7M ohm  = yellow, purple, green, gold.



Step 7

Place a yellow alligator clip on Leg#2 row, and another on GND
Place a blue alligator clip on Leg#6 row, and another on +V rail.`



Attach Conductive Sensors



Turn the LED ON/OFF

ON OFF



Turn the LED ON/OFF

ON OFF



Other Ideas

• You can make your own touch sensors

• Draw different contact pads

• Use the conductive paint to make more 
complicated patterns and circuits

• OR use the same circuit but instead of conductive 
paint you can use cardboard and aluminum foil to 
make a pressure sensor



Questions?



Project 03 – Materials

22 AWG wire

9V Battery

Breadboard

0.01 uF Cap.

555 IC

Speaker

100 uF Cap.

1k ohm

10k ohm 
Potentiometer



Project 03 - Schematic

100 uF
capacitor

0.01 uF
capacitor

1k ohm 
resistor

10k ohm 
potentiometer



Step 1

Add +V and GND wires to power rails, and add jumpers across.



Step 2

Add 555 timer to the middle of the board, dimple facing LEFT.



Step 3

Jump Leg#1 to GND, jump Leg#4 to +V, jump Leg#8 to +V.

8
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4



Step 4

Use a short yellow wire, jump from Leg#2 to Leg#6.
Jump a 1k ohm resistor from Leg#7 to +V. (brown, black, red, gold)

2

6
7



Step 5

6

Place long leg of large capacitor, 100 uf, into Leg#3.
Add a small capacitor, 0.01 uf (103), from  Leg#6 to GND.

3



Step 6

Add the speaker, one wire from speaker to short leg of 100 uf cap,
Add the second wire to GND. Note: Speakers not polarized.



Step 7

Add the 10k ohm potentiometer to the breadboard, top left.



Step 8

Jump left leg of pot to GND, right leg of pot to Leg#2,
Middle leg of pot to Leg#7. Then turn on battery switch!



Astable mode - How it works

As we rotate the potentiometer, we change the input resistance.
This change in resistance controls frequency of the output pulses.

Short pulses lead to higher frequency noise from the speaker.



Questions?



LUNCH

Note: If you do not have the Arduino IDE installed, please 
install during lunch. If you need help, let us know!



Workshop 1 - Outline

• What is Arduino? (hardware and software)
• Types of Arduino microcontrollers
• Arduino UNO Specifications
• Integrated Programming Environment - IDE
• Programming basics



Types of Arduinos
Uno - $25 Mega 2560 - $46

Leonardo - $25
DUE - $50

Pro Mini - $10

Arduino Mini - $20

Presenter
Presentation Notes
Uno – standard – ATMega328 – 16 Mhz – 14 I/O pins
Mega – more IO pins  ATMega 2560 chipset – 16 MHz – 54 I/O pins

Leonardo – ATMega 32u4 – 16 Mhz oscialltor – 20 I/O – built in USB communication – looks like a device when you plug it in
Due – based on ARM Cortext M3 – only 3.3V, 32 bit,  84 MHz

Mini – Atmega328 – 16 Mhz



Arduino Alternatives
Ti Launch Pad MSP430

Picaxe 28X2 Shield Base Parallax Propeller ASC+

NetDuino Plus 2

Presenter
Presentation Notes
Ti Launch Pad MSP430 --  Low price- $10. Uses Energia prototyping platform to upload code. Updated and improved, now can drag and drop Arduino code and it will work with board.

Picaxe 28X2- same form factor, used BASIC for programming. Compatible with shields.

NetDuino Plus 2 – ARM Cortex based – 32 bit. Used .NET framework (windows!) Programing in C# directly from Visual C# Express.

Parallax Propeller ASC+ – same form factor, eight processors – able to read sensor inputs and respond using eight simulaneous loops. Only 50$ more, ideal for project with lots of intereups.




Build your own Arduino

Adafruit MENTA -$35 Makershed MintDuino -$25



Going Wireless
Arduino YUN Pinoccio

BLEduino Geogram One



Single Board Computers & FPGA
BeagleBone Black Raspberry Pi

MojoPapilio One



Arduino UNO Pin Layout

Reset Digital I/O pins

Analog pinsPower and GND



Types of chips: SMD vs. DIP

Dual in-line package Surface mount device 

Presenter
Presentation Notes
DIP – two parallel rows of pins

SMD- surface mount device



Arduino IDE



Programming Environment
IDE version 

serial port 
connection

file name

IDE features

code goes
here

type of Arduino



Arduino IDE Interface

new open save

uploadverify serial monitor



Questions?



Project 4 – Blink

Place yellow wire in Pin 5, NOT Pin 13
(this image is incorrect)



File> Example> 01.Basics> Blink



Sketch layout
• Add libraries, write comments, and declare variables 

– Very first thing, add reference to library files
– Set constants, define variables
– Important, if you define a variable within a loop, it cannot be used outside of 

that loop
• void setup()

– Declare pinmodes, set the pins for inputs and outputs
– Setup serial monitor for communication 

• void loop()
– Runs your code
– Starts at the top, ends at the bottom, then repeats
– This is where you read sensors, compute values and control the outputs
– The more stuff in the void loop, the longer it takes to cycle through the loop 

and get back to the start
• Define functions

– Define functions to be used in the program (can also be at beginning).



Blink Sketch

Write comments

void setup()

void loop ()



Edit the Blink sketch

• The standard sketch uses Pin 13.
• At the factory, each Uno is tested with this 

sketch to make sure it works properly.
• An onboard LED will blink once you connect 

the USB cable.
• To test our circuit, we need to change every 

instance of 13 to 5 so the Arduino knows we 
plugged the LED into a Pin 5.



Edit the Blink Sketch



Tools > Board > Arduino UNO



Tools > Port > usbmodem###

Note: Arduino must be 
connected to computer 

with USB cable.



Upload



The LED should Blink!
• If not, check the wiring to Pin 5
• Then check the code
• If you get an error message, make sure you 

change the port and board settings.



Now, make the code more flexible



But, how can we control the 
brightness of the LED?



Digital vs. Analog Outputs

• Digital – either ON or OFF
– Binary, we use either 0 or 1, HIGH or LOW

• 0 = false (off)
• 1 = true (on)

• Analog – range of values
– Hardware >>> analog to digital convertor (A/D)
– Reads digital signal, discretizes it into range of values
– UNO has 10 bit A/D, so values range 0-1023 (note: 210 =1023)

– Arduino can both read and send analog signals*



PWM with analogWrite()

analogWrite() from scale 0-255



Arduino PWM



File> Example> Basic> Fade



File> Example> Basic> Fade



Questions?



Outputs - RGB LED

Red

Green
Blue

+V



Types of RGB LED

Common Anode

+V

GND GND GND

Common Cathode

+V +V +V

GND



Standard RGB LED Colors

• Red
• Green
• Blue
• Red + Green
• Red + blue
• Green + Blue
• Red + Green + Blue



Project 5 – Color Changing RGB LED



Project 5 – Color Changing RGB LED



Sketch Layout

Define variables

void setup()

void loop()

Function definition



Project_05_RGB_LED



Project_05_RGB_LED



• Plug in the Arduino, upload the code and the 
RGB LED should start to change colors.

• If not, check the wiring and double check the 
value of the resistors.

• They should be 330 ohm (orange, orange, 
brown, gold)



Questions?



Resistive Sensors

• NTCT Thermistor - NTC-type thermistors decrease in resistance as temperature rises.
• Photoresistor – When exposed to more light, the resistance goes down. 
• Force Sensitive Resistor – Resistance decrease when force is applied.  

Cds Photoresistor

Force Sensitive Resistor
NTC Thermistor

Presenter
Presentation Notes
Thermistor - NTC-type thermistors decrease in resistance as temperature rises. 

Photoresistor - As the squiggly face is exposed to more light, the resistance goes down. When its light, the resistance is about 5-10KΩ, when dark it goes up to 200KΩ.

FSR - Variable resistors that decrease in resistance when pressed 



Voltage Divider

• Arduino does not have 
a resistance meter,

• Must convert change 
in resistance into 
chance in voltage. 

• Read with A/D.



Force Sensitive Resistors



Build the Circuit



Step 1



Step 2



Step 3



Step 4



Project 6 – Force Sensitive Resistor



Project 6 – Force Sensitive Resistor



Sensor Readings



Project 06 - Squeeze Gauge



Project 06 – Squeeze Gauge



Questions?



Inputs and Outputs

Outputs
(LEDs, motor, 

speaker)

Logic, make 
decisions, 

change 
variables…

Inputs
(digital and 

analog 
sensors)



Build the Circuit



Project 7 – AnalogInput



Project 7 – AnalogInput Code



Project 7 – AnalogInput Code



Questions?
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